うまいぼうぶろぐ

linuxとhttpdとperlのメモ

Perlをthreadsを有効にしてコンパイル

古いサーバ(linux kernel 2.4.20)でperl5.10を

$ ./Configure -des -Dprefix=/usr/local/perl5.10

で入れたら、threadsが有効にならなかった。(slowlorisが動かない)

$ perl slowloris 
This Perl not built to support threads

コンパイルしなおし。

$ ./Configure -des -Dprefix=/usr/local/perl5.10 -Dusethreads